0

Just getting started on Docker and after installing Docker Desktop on a Windows 10 Pro machine, the option to enable Kubernetes is missing from the context menu when using Windows containers. See the attached image. When I switch to Linux containers the option appears. Various reading I've done seems to indicate that it should be available to Windows containers too. What am I missing?

Windows 10 Pro (10.0.17134.1006)

Docker Desktop 2.1.0.5

enter image description here

After update:

enter image description here

Settings after update:

enter image description here

2 Answers 2

3

You need to first switch to Edge version by going to the

Docker -> Settings -> General tab.

Then, you have to enable the kubernetes.

Open Docker for Windows settings by accessing your system tray and navigate to the Kubernetes tab. Select the checkbox for Enable Kubernetes to start a single-node cluster when starting Docker.

Reference: https://medium.com/@damiannolan/kubernetes-on-docker-for-windows-5ca0c6395668

As per this old link and a latest one, Kubernetes needs a Linux master node and thus the kubernetes cluster can be initialized only from linux containers in Docker desktop for Windows. After enabling and starting the docker containers, you can add Windows containers the the running kubernetes cluster.

This will give you much clear context.

6
  • 1
    Could you mark the answer as accepted if it solved the issue?
    – 030
    Dec 20, 2019 at 14:25
  • Thanks for the quick reply, however after I updated to 2.1.7.0 edge, the option still doesn't appear with Windows containers.
    – ACB
    Dec 20, 2019 at 16:53
  • What all options you see when you click on settings
    – Samit
    Dec 20, 2019 at 16:55
  • Left side tabs: General, Resources, Docker Engine, Command Line
    – ACB
    Dec 20, 2019 at 16:57
  • Updated original post with screen caps
    – ACB
    Dec 20, 2019 at 17:11
0

As Samit commented, the options for Kubernetes are only available if Linux containers are currently set as the environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.