3

I have used 0.9.x Graphite in the past as the basis of my monitoring system, and am trying a fresh install of 1.0.1 prior to upgrading across my systems (Ubuntu, 14.04, though I doubt that matters).

I appear to have graphite-webapp and carbon-cache running (supervisorctl reports both as RUNNING, and there are not errors in any logs I can find). I have confirmed by navigating in the server /opt/graphite/webapp/storage/whisper/ that there is in fact data to display in the first place.

I am able to access http://localhost:8080 and see the usual graphite webapp header, but the body of the page is blank (where normally I would expect to see the file-browser that lets me choose data on the left, and it graphs the selected data on the right).

To the best of my knowledge, I have configured graphite as per the installation instructions, but obviously I have done something wrong.

If there are particular configuration files that would be useful for me to include (which can also server as a debugging path for future people who may have this issue), please comment the files that may help.

Note to editor: The tag should be "graphite", probably, but I don't have the rep to tag it correctly.

  • 1
    What does /var/log/httpd/error_log show? Can you post the header with curl -i http://localhost:8080? – James Shewey Jul 7 '17 at 0:41
  • Also check the browser error console to see if there are 404s, etc. – Xiong Chiamiov Jul 7 '17 at 17:54
2

You need to collect static assets in your Django

cd /opt/graphite/webapp && PYTHONPATH=/opt/graphite/webapp django-admin.py collectstatic --noinput --settings=graphite.settings

Static files will be installed in /opt/graphite/static. Then you need to configure your webserver to serve them directly. For Nginx something like:

location /static {
   root /opt/graphite
}
  • Are you sure they are even using nginx? My understanding is that graphite runs on apache by default – James Shewey Jul 7 '17 at 14:57
  • That is exactly correct. For those who come after me, the symptom of this problem is precisely what I described (the blank screen but functional header), and also the browser console displayed many 404's - all the js and css that builds the content of the page is static files which were not able to be found.) For some reason, python-whitenoise which I was using for static files was failing silently. Running the command as suggested here worked, of course. BUT - the STATIC_ROOT by default is /opt/graphite/static, so that is what you should point your webserver to (NOT /opt/graphite). – fildred13 Jul 7 '17 at 16:16
  • @fildred13 @james-shewey : yes, sorry, should mention Apache as well - but I have no example of Apache config. Please note that Nginx config above is from working configuration, it's pointing static files exactly to /opt/graphite/static – deniszh Jul 7 '17 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.