2

After instalating Docker from repo I can't run it. Problem is with daemon:

dockerd
INFO[2018-04-16T09:35:46.054942906+02:00] libcontainerd: started new docker-containerd process  pid=21656
INFO[0000] starting containerd                           module=containerd revision=773c489c9c1b21a6d78b5c538cd395416ec50f88 version=v1.0.3
INFO[0000] loading plugin "io.containerd.content.v1.content"...  module=containerd type=io.containerd.content.v1
INFO[0000] loading plugin "io.containerd.snapshotter.v1.btrfs"...  module=containerd type=io.containerd.snapshotter.v1
WARN[0000] failed to load plugin io.containerd.snapshotter.v1.btrfs  error="path /var/lib/docker/containerd/daemon/io.containerd.snapshotter.v1.btrfs must be a btrfs filesystem to be used with the btrfs snapshotter" module=containerd
INFO[0000] loading plugin "io.containerd.snapshotter.v1.overlayfs"...  module=containerd type=io.containerd.snapshotter.v1
INFO[0000] loading plugin "io.containerd.metadata.v1.bolt"...  module=containerd type=io.containerd.metadata.v1
WARN[0000] could not use snapshotter btrfs in metadata plugin  error="path /var/lib/docker/containerd/daemon/io.containerd.snapshotter.v1.btrfs must be a btrfs filesystem to be used with the btrfs snapshotter" module="containerd/io.containerd.metadata.v1.bolt"
INFO[0000] loading plugin "io.containerd.differ.v1.walking"...  module=containerd type=io.containerd.differ.v1
INFO[0000] loading plugin "io.containerd.gc.v1.scheduler"...  module=containerd type=io.containerd.gc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.containers"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.content"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.diff"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.events"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.healthcheck"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.images"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.leases"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.namespaces"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.snapshots"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.monitor.v1.cgroups"...  module=containerd type=io.containerd.monitor.v1
INFO[0000] loading plugin "io.containerd.runtime.v1.linux"...  module=containerd type=io.containerd.runtime.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.tasks"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.version"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] loading plugin "io.containerd.grpc.v1.introspection"...  module=containerd type=io.containerd.grpc.v1
INFO[0000] serving...                                    address="/var/run/docker/containerd/docker-containerd-debug.sock" module="containerd/debug"
INFO[0000] serving...                                    address="/var/run/docker/containerd/docker-containerd.sock" module="containerd/grpc"
INFO[0000] containerd successfully booted in 0.007348s   module=containerd
ERRO[2018-04-16T09:35:46.318603395+02:00] 'overlay' not found as a supported filesystem on this host. Please ensure kernel is new enough and has overlay support loaded.
ERRO[2018-04-16T09:35:46.321272231+02:00] 'overlay' not found as a supported filesystem on this host. Please ensure kernel is new enough and has overlay support loaded.
INFO[2018-04-16T09:35:46.334031676+02:00] Graph migration to content-addressability took 0.00 seconds
WARN[2018-04-16T09:35:46.337419439+02:00] Your kernel does not support swap memory limit
WARN[2018-04-16T09:35:46.337438494+02:00] Your kernel does not support memory reservation
WARN[2018-04-16T09:35:46.337452567+02:00] Your kernel does not support oom control
WARN[2018-04-16T09:35:46.337465274+02:00] Your kernel does not support memory swappiness
WARN[2018-04-16T09:35:46.337479319+02:00] Your kernel does not support kernel memory limit
WARN[2018-04-16T09:35:46.337488145+02:00] Unable to find cpu cgroup in mounts
WARN[2018-04-16T09:35:46.337501250+02:00] Your kernel does not support cgroup blkio weight
WARN[2018-04-16T09:35:46.337515483+02:00] Your kernel does not support cgroup blkio weight_device
WARN[2018-04-16T09:35:46.337528836+02:00] Your kernel does not support cgroup blkio throttle.read_bps_device
WARN[2018-04-16T09:35:46.337542675+02:00] Your kernel does not support cgroup blkio throttle.write_bps_device
WARN[2018-04-16T09:35:46.337556361+02:00] Your kernel does not support cgroup blkio throttle.read_iops_device
WARN[2018-04-16T09:35:46.337571999+02:00] Your kernel does not support cgroup blkio throttle.write_iops_device
WARN[2018-04-16T09:35:46.337589881+02:00] Unable to find cpuset cgroup in mounts
WARN[2018-04-16T09:35:46.337656042+02:00] mountpoint for pids not found
Error starting daemon: Devices cgroup isn't mounted

I installed cgroup manualy:

apt-get install cgroupfs-mount

But still this same issue. Is really a kernel from 2016 year too old?

uname -a retruns:

Linux xxx 3.16.0-042stab127.2 #1 SMP Thu Jan 4 16:41:44 MSK 2018 x86_64 GNU/Linux

5
  • Are you running as root? Or have you assigned your user to the a Docker group? – dburke1 Apr 16 '18 at 8:56
  • 1
    Did you try to fix the error messages? First and foremost, "overlay not found as supported filesystem". – AnoE Apr 17 '18 at 19:47
  • 1
    I think your kernel is too old – Software Engineer Apr 22 '18 at 1:33
  • 1
    The real error is: "ERRO[2018-04-16T09:35:46.318603395+02:00] 'overlay' not found as a supported filesystem on this host. Please ensure kernel is new enough and has overlay support loaded.", I think your kernel is too old for overlay and only support aufs, so either downgrade docker or (better IMHO) upgrade your system. – Tensibai May 22 '18 at 12:54
  • What version of docker are you running, and what repo did you install it from? What distro are you running for your host? What options have you configured for the daemon, including settings in /etc/docker/daemon.json and flags passed in the startup scripts? – BMitch May 22 '18 at 20:37
1

Try the following as root:

  • Edit the /etc/default/grub file and set the GRUB_CMDLINE_LINUX value as follows:

    GRUB_CMDLINE_LINUX="cgroup_enable=memory swapaccount=1"

  • Update GRUB.

    sudo update-grub

  • Reboot your system.

As per this docker's documentation.

2
  • I don't think this apply to the question, the problem seems more widespread than just swap limitation. – Tensibai May 22 '18 at 12:53
  • Indeed I think he has an outdated kernel version, an update-grub would solve the issue but without activating swap capabilities a warning would still appear in the logs – storm May 22 '18 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.