1

I have gitlab runner with, docker as executor and docker:latest as default image.

Runner is connected to the project and runs pipeline, but it stuck at

Reinitialized existing Git repository in /builds/sachith/omy-project/.git/

fatal: unable to access 'https://gitlab.myhost.com:1234/sachith/omy-project.git/': Failed to connect to gitlab.myhost.com port 1234: Operation timed out

I logged to gitlab-runner running server and tried cloning project as gitlab-runner user and it worked.

Why am I getting this error?

2

This is likely because your requests were dropped before they landed on the GitLab host. Check your firewalls and other security rules after assured that the 1234 port is open

1
  • Port is open and can access to it. Will check and let you know. – Sachith Muhandiram Feb 6 at 15:47
0

It was a simple mistake I made when I register gitlab-runner. I just used gitlab-runner register [options]

But when I register it with sudo, it was working properly.

sudo gitlab-runner register [option]

Runner is running in Ubuntu-18.04 server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.