2

I've set the environment variable with a "context" (I have no idea if thats the right place - it's really confusing!)

None the less, it's now doing a build - and I don't see the environment variables set (I'm using the SSH build to inspect the vars with getenv).

Why is it not being picked up? Am I meant to set an environment variable by some other means rather than a "context"?

1

https://circleci.com/docs/2.0/env-vars/#setting-an-environment-variable-in-a-project

Seems "contexts" can be used but must then also be set to "reference" the context in the build yaml config file.

Instead to set a environment variable for a project: Jobs > Cog / gear icon of a project > Build settings > Environment variable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.